Wan_lb: failure to insert default route on active path

wan_lb might have a bug

Update Correction! Not a bug. My error in configuration.

/var/log/messages shows this error every few seconds
vyos wan_lb: failure to insert default route on active path with this command: ip route replace table 202 default dev eth1 via 97.122.107.1

manually entering the command results in error
Error: Nexthop has invalid gateway.

manually adding the parameter ‘onlink’ to the command eliminates the error
ip route replace table 202 default dev eth1 via 97.122.107.1 onlink

version VyOS 1.4-rolling-202211260318
config
set load-balancing wan interface-health eth0 failure-count ‘1’
set load-balancing wan interface-health eth0 nexthop ‘71.157.36.1’
set load-balancing wan interface-health eth0 success-count ‘1’
set load-balancing wan interface-health eth1 failure-count ‘1’
set load-balancing wan interface-health eth1 nexthop ‘98.122.107.1’
set load-balancing wan interface-health eth1 success-count ‘1’

interfaces
eth0 71.157.37.1/22 u/u WAN1
eth1 98.122.103.96/23 u/u WAN2

after adding onlink
ip route show table 202
default via 98.122.107.1 dev eth1 onlink

There is a known bug, task T4362

Ok. I am not using the ‘dhcp’ option so I thought this was different from ⚓ T4362 Wan Load Balancing - Can't create routing tables. Sorry.

Ah so maybe it is another bug :slight_smile:

eth1 nexthop ‘98.122.107.1’

maybe typo in the address?

My fault. My ISP changed the next hop and I didn’t change it in the load balancing configuration. I am glad it was NOT another bug.
Thanks.