why dhcpd3 listen on raw port 1 ?


#1

I install vyos , and hack it .
I delete the file ntpd , to forbid the listen on port 53
but , I still found the dhcpd3 listen on raw port 1.
Is it a backdoor ?
and how can I forbid it ?

raw 0 0 0.0.0.0:1 0.0.0.0:* 7 3387/dhcpd3


ok.
I got to know why : the bootp protocol is enabled.
to get rid of it :

set service dhcp-server shared-network-name LAN subnet 192.168.19.0/24 subnet-parameters “pool { deny dynamic bootp clients; }”

all the config of my vyos is :

show service dhcp-server
disabled false
dynamic-dns-update {
enable false
}
shared-network-name LAN {
authoritative disable
subnet 192.168.XX.0/24 {
default-router 192.168.XX.1
dns-server 192.168.XX.1
domain-name internal-network
lease 86400
start 192.168.XX.100 {
stop 192.168.XX.200
}
subnet-parameters “host h1_linux_33 { hardware ethernet 00:XX:X:XX:XX:9e ; fixed-address 192.168.XX.33 ; }”
subnet-parameters “pool { deny dynamic bootp clients; }”
}
}