Why does VyOS not respond to OSPF hello?

After some break I started playing with VyOS 1.4 RC again. I have a wireguard tunnel to a Linux box with bird. I am really confident the last time this worked with this configuration. But now nothing happens (neighbors do not show up on both sides).

It’s always OSPF. Why does OSPF have to be so painful?

I am doing a tcpdump -i wg0 "ip[9] == 89" -n on both sides. I see the linux box successfully transmitting the multicast packets:

08:11:56.411909 IP bgate1 > ospf-all.mcast.net: OSPFv2, Hello, length 44

On the VyOS box I see exactly this packet being received on wg0. But no response. I have no firewall enabled, the allowed IPs for the tunnel are (otherwise the multicast packet wouldn’t even be received) and I have enabled OSPF on both sides as ptp:

 area {
 interface eth0.2 {
     passive {
 interface wg0 {
     authentication {
         md5 {
             key-id 1 {
                 md5-key secret
     cost 100
     dead-interval 40
     hello-interval 10
     network point-to-point
     priority 1
     retransmit-interval 5
     transmit-delay 1
 parameters {
     abr-type cisco
 passive-interface default

Similarly my bird config:

interface "wg0" {                                                                                                                            
  cost 100;hello 10;retransmit 5;wait 5;dead 40;                                                                                                 
  type ptp;                                                                                                                                                                                                                                                            
  authentication cryptographic;                                                                                                                  
  password "secret" {                                                                                                                  
    id 1;                                                                                                                                  

What else can I verify?

According to the manual the fact you’ve set passive interface default means you need to specifically exclude wg0 for OSPF to form an adjacency on the interface.


Wow that was it, thanks!!

Note however that config seems to have changed for 1.4. It needs to be now set protocol ospf interface wg0 passive disable.

This is probably the reason why I remember it used to work … because that’s config from 1.3.
When importing the config for 1.4, that entry was probably dropped …

Ahh yup sorry that was my bad quoting the 1.3 doco, I didn’t check the 1.4 sorry.

Glad it’s sorted :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.