Wireless with hw_mode=a and ACS does not work

wireless

#1

I am trying to run hw_mode=a and with channel=0 but hostapd gives me an error on start.

#sudo hostapd /var/run/hostapd/wlan4.cfg

hostapd: /usr/lib/aarch64-linux-gnu/libssl.so.1.0.0: no version information available (required by hostapd)
hostapd: /usr/lib/aarch64-linux-gnu/libssl.so.1.0.0: no version information available (required by hostapd)
hostapd: /usr/lib/aarch64-linux-gnu/libcrypto.so.1.0.0: no version information available (required by hostapd)
Configuration file: /var/run/hostapd/wlan4.cfg
wlan4: interface state UNINITIALIZED->COUNTRY_UPDATE
ACS: Automatic channel selection started, this may take a bit
wlan4: interface state COUNTRY_UPDATE->ACS
wlan4: ACS-STARTED
ACS: Unable to collect survey data
ACS: All study options have failed
Interface initialization failed
wlan4: interface state ACS->DISABLED
wlan4: AP-DISABLED
ACS: Possibly channel configuration is invalid, please report this along with your config file.
ACS: Failed to start
wlan4: AP-DISABLED
hostapd_free_hapd_data: Interface wlan4 wasn’t started
wlan4: interface state DISABLED->DISABLED
hostapd_free_hapd_data: Interface wlan4 wasn’t started

Hostapd Config File

Hostapd configuration for wlan4

interface=wlan4
driver=nl80211
logger_syslog=-1
logger_syslog_level=0
logger_stdout=-1
logger_stdout_level=4
country_code=US
ieee80211d=1
ssid=testfloor1
channel=0
hw_mode=a
ieee80211w=0
macaddr_acl=0
max_num_sta=5
ap_isolate=1
auth_algs=1
tx_queue_data3_aifs=7
tx_queue_data3_cwmin=15
tx_queue_data3_cwmax=1023
tx_queue_data3_burst=0
tx_queue_data2_aifs=3
tx_queue_data2_cwmin=15
tx_queue_data2_cwmax=63
tx_queue_data2_burst=0
tx_queue_data1_aifs=1
tx_queue_data1_cwmin=7
tx_queue_data1_cwmax=15
tx_queue_data1_burst=3.0
tx_queue_data0_aifs=1
tx_queue_data0_cwmin=3
tx_queue_data0_cwmax=7
tx_queue_data0_burst=1.5
wmm_ac_bk_cwmin=4
wmm_ac_bk_cwmax=10
wmm_ac_bk_aifs=7
wmm_ac_bk_txop_limit=0
wmm_ac_bk_acm=0
wmm_ac_be_aifs=3
wmm_ac_be_cwmin=4
wmm_ac_be_cwmax=10
wmm_ac_be_txop_limit=0
wmm_ac_be_acm=0
wmm_ac_vi_aifs=2
wmm_ac_vi_cwmin=3
wmm_ac_vi_cwmax=4
wmm_ac_vi_txop_limit=94
wmm_ac_vi_acm=0
wmm_ac_vo_aifs=2
wmm_ac_vo_cwmin=2
wmm_ac_vo_cwmax=3
wmm_ac_vo_txop_limit=47
wmm_ac_vo_acm=0


#2

I found it working with different hardware.
So, not related to VYOS.


#3

Cool, I was about to write that your wifi chip has to support it too :).


#4

hi,
hagbard,

It ran once,
but after some time,
Even with second hardware chip it is not working anymore.
chip`s(compex WLE900VX) specification says, it support 2.4Ghz and 5Ghz mode.

I am using following set of vyos commands:

#delete interfaces wireless
#commit

#set interfaces wireless wlan0 physical-device phy0
#set interfaces wireless wlan0 hw-id xx:xx:xx:xx:xx:xx
#set interfaces wireless wlan0 mac xx:xx:xx:xx:xx:xx
#commit

#set interfaces wireless wlan0 type access-point
#set interfaces wireless wlan0 mode a
#set interfaces wireless wlan0 channel 0
#set interfaces wireless wlan0 ssid testSSID0
#commit

#sudo /opt/vyatta/sbin/hostapd-init restart wlan0

it did not start testSSID0.
to debug the issue, I even tried to run the hostapd manually using

#sudo hostapd /var/run/wlan0.cfg
but I get error as
hostapd: /usr/lib/aarch64-linux-gnu/libssl.so.1.0.0: no version information available (required by hostapd)
hostapd: /usr/lib/aarch64-linux-gnu/libssl.so.1.0.0: no version information available (required by hostapd)
hostapd: /usr/lib/aarch64-linux-gnu/libcrypto.so.1.0.0: no version information available (required by hostapd)
Configuration file: /var/run/hostapd/wlan0.cfg
wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
ACS: Automatic channel selection started, this may take a bit
wlan0: interface state COUNTRY_UPDATE->ACS
wlan0: ACS-STARTED
ACS: Unable to collect survey data
ACS: All study options have failed
Interface initialization failed
wlan0: interface state ACS->DISABLED
wlan0: AP-DISABLED
ACS: Possibly channel configuration is invalid, please report this along with your config file.
ACS: Failed to start
wlan0: AP-DISABLED
hostapd_free_hapd_data: Interface wlan0 wasn’t started
wlan0: interface state DISABLED->DISABLED
hostapd_free_hapd_data: Interface wlan0 wasn’t started

Kindly, try to follow the steps above, I am sure you will be able to see or reproduce the same error as me.


#5

I see that I can have a look into it this weekend.