Xe-guest-utility issue in VYOS as VM in Citrix XenServer (Hypervisor) 8.2 CU1

Hi there,

We are using the VYOS routers as VM on Citrix Xenserver
Latest successfully used (monthly) build is 1.3-202101.

Recently we have decided to upgrade all VMs to more fresh build.
1st attempt was with latest 1.3 build from source as stated in documentation.
Upgrade went almost smoothly but there is an issue with xe-guest-utility (driver to communicate with hypervisor)

Usually we just deleted vyos-xe-guest-utility packet installed in the image (because they didn’t recognized by hypervisor) and than installed latest xe-guest-utility from citrix.

I/O optimized
> Management Agent not installed
Not able to receive updates from Windows Update

With latest 1.3 we have done the same but can’t start update utility giving the quite strange message

~$ sudo systemctl start xe-guest-utility
Failed to start xe-guest-utilities.service: Unit proc-xen.mount is masked.

Same issue happens with 1.4 latest.

Is there any idea what does it mean “Unit proc-xen.mount is masked” and how fix it?


I have unmasked proc-xen.mount by and then successfully started service

$sudo systemctl unmask proc-xen.mount
$ sudo systemctl start xe-guest-utilities.service
$ sudo systemctl status xe-guest-utilities.service
● xe-guest-utilities.service - Xen Guest Monitoring Agent
     Loaded: loaded (/etc/systemd/system/xe-guest-utilities.service; enabled; vendor preset: enabled)
     Active: active (running) since Mon 2022-02-21 10:54:06 EET; 1min 15s ago
   Main PID: 784 (xe-daemon)
      Tasks: 10 (limit: 1128)
     Memory: 24.1M
        CPU: 1.316s
     CGroup: /system.slice/xe-guest-utilities.service
             ├─784 /usr/sbin/xe-daemon
             ├─851 logger -t xe-daemon
             └─861 logger -t xenstore

But hypervisor still didn’t see the agent

I/O optimized
Management Agent not installed
Not able to receive updates from Windows Update

Any help highly appreciated.

It seems you needs images for xcp-ng they already have required tools

Thanks, but I didn’t see any XCP-ng related images.
Would you please point out ?


Have found this topic
:anchor: T4034 “make xcp-ng-iso” still includes vyos-xe-guest-utilities

tried to build the XCP-ng ISO from source
$ sudo make xcp-ng-iso

Image definitely changed - instead of vyos-xe-guest xe-linux-utilities appeared.

But hypervisor still not recognized management agent.

Do they provide their own utils from their own repo or from debian?

Sorry, don’t understand question.

I got everything from vyos repositories accordingly to below instruction

This one a little bit friendly

Could you sent a link?

Sorry, it is protected resource on citrix web site. No public available download.
i could share image if you accept it (google disk is ok?)

So we can’t add it to our releases.

Sure, but some times ago it could be installed.
Simply remove existing and add new one.
As I told in start topic - vyos 1.3 202101 month release worked without any issue.