High CPU usage by bgpd when snmp is active



I have the same problem and worked well after restart snmp service, but when i reboot the router the /etc/default/snmp file goes to default again, I notice that is modified by the script snmp.py but theres multiples snmp.py files What file should modifiy so, after a router reboot get the right snmp config?

the files I found are the following
Which one should I modify?

You can try change /usr/libexec/vyos/conf_mode/snmp.py or build own vyos-1x with this changes, or wait for this task https://phabricator.vyos.net/T1705

Thanks a lot I Found it and change line 220 I comment the old one use as seen below

# SNMP template (/etc/default/snmpd) - be careful if you edit the template.
init_config_tmpl = """
### Autogenerated by snmp.py ###
# This file controls the activity of snmpd

# snmpd control (yes means start daemon).

# snmpd options (use syslog, close stdin/out/err).
# SNMPDOPTS='-LSed -u snmp -g snmp -p /run/snmpd.pid' 
SNMPDOPTS='-LSed -u snmp -g snmp -I -ipCidrRouteTable,inetCidrRouteTable -p /run/snmpd.pid'

I’m going to implement https://phabricator.vyos.net/T1705 today for rolling.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.